Library compatibility

The Appsfire iOS SDK supports all iOS 6.0 and above versions. It compiles against the armv7 and arm64 architectures (+ i386 and x86_64 for the simulator).
Certain features require that your app have a normalized version number (e.g. 1, 2.0, 2.1.2, 4.1.4.2) and that this version number be properly declared in your main plist. See the FAQ section for more details.

Xcode

We are using Xcode 7 to create our demo projects. You may encounter some errors if you are using a lower version of Xcode. That's why we recommend you work on the latest (non-beta) available version.

Sample projects

We provide sample projects to help you implement our SDK.
These sample projects can be downloaded from Dashboard, or from Github.

Get the Appsfire iOS SDK

Cocoapods

The recommended approach for installing AppsfireSDK is via the CocoaPods package manager, as it provides flexible dependency management and dead simple installation.
For best results, it is recommended that you install via CocoaPods >= 0.28.0 using Git >= 1.8.0 installed via Homebrew.

Install CocoaPods if not already available:

$ [sudo] gem install cocoapods
$ pod setup

Change to the directory of your Xcode project:

$ cd /path/to/MyProject
$ touch Podfile
$ edit Podfile

Edit your Podfile and add AppsfireSDK:

platform :ios, '6.0'
pod 'AppsfireSDK'

Install into your Xcode project:

$ pod install

Open your project in Xcode from the .xcworkspace file (not the usual project file)

$ open MyProject.xcworkspace

Please note that if your installation fails, it may be because you are installing with a version of Git lower than CocoaPods is expecting. Please ensure that you are running Git >= 1.8.0 by executing git --version. You can get a full picture of the installation details by executing pod install --verbose.

Download the Appsfire iOS SDK

The SDK can be downloaded from the Appsfire dashboard or from Github



documentation-dashboard